Share if you like

SquidAPI 1.7.10 is a library mod required for some of CoolSquid’s mods to function.

SquidAPI

Requires:

Minecraft Forge

How to install:

    How To Download & Install Mods with Minecraft Forge
    How To Download & Install Fabric Mods

SquidAPI 1.7.10 Download Links:

For Minecraft 1.7.10

Download from Server 1Download from Server 2

Click to rate this post!
[Total: 0 Average: 0]

Share if you like