Minecraft Mods, Resource Packs, Texture Packs, Maps

Minecraft 1.4.7 Mods

Highlands-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: sdj64
Updated: April 20, 2014 | Comments
91,489 views
GD Star Rating
loading...
Secret-Rooms-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.5.2
Author: AbrarSyed
Updated: April 20, 2014 | Comments
135,821 views
GD Star Rating
loading...
Flans-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: jamioflan
Updated: April 18, 2014 | Comments
690,532 views
GD Star Rating
loading...
Thaumcraft-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: Azanor
Updated: April 18, 2014 | Comments
540,595 views
GD Star Rating
loading...
Mutant-Creatures-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: thehippomaster21
Updated: April 18, 2014 | Comments
292,824 views
GD Star Rating
loading...
Dragon-Mounts-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: BarracudaATA
Updated: April 18, 2014 | Comments
194,593 views
GD Star Rating
loading...
Falling-Meteors-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: AlexDGr8r
Updated: April 18, 2014 | Comments
130,167 views
GD Star Rating
loading...
Trapcraft-Mod
Compatible with Minecraft: 1.7.2, 1.6.2
Author: ProPercivalalb
Updated: April 17, 2014 | Comments
66,178 views
GD Star Rating
loading...
Kirby-Enemy-Mod
Compatible with Minecraft: 1.7.2, 1.6.2, 1.5.2
Author: Kickflip147
Updated: April 14, 2014 | Comments
50,451 views
GD Star Rating
loading...
Just-Another-Spawner-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: Crudedragos
Updated: April 14, 2014 | Comments
47,879 views
GD Star Rating
loading...
Equivalent-Exchange-3
Compatible with Minecraft: 1.6.4, 1.6.2, 1.5.2
Author: Pahimar
Updated: April 13, 2014 | Comments
238,978 views
GD Star Rating
loading...
The-Lord-of-the-Rings-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: Mevans
Updated: April 12, 2014 | Comments
211,141 views
GD Star Rating
loading...
Sushi-Craft-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: KingstoneKingdome
Updated: April 12, 2014 | Comments
42,072 views
GD Star Rating
loading...
Toomanyitems
Compatible with Minecraft: 1.7.9, 1.7.5, 1.7.4, 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: Marglyph
Updated: April 12, 2014 | Comments
2,188,367 views
GD Star Rating
loading...
Ropes-Plus-Mod
Compatible with Minecraft: 1.7.2, 1.6.4, 1.6.2, 1.5.2
Author: AtomicStryker
Updated: April 7, 2014 | Comments
102,698 views
GD Star Rating
loading...
Share this:

Enter your email address: