Share if you like

Legends Core 1.7.10 is the core-mod that all the Legends Modding Team’s mods run from. This mod is required to be installed in order to use any of the others.

Legends Core

Requires:

Minecraft Forge

How to install:

    How To Download & Install Mods with Minecraft Forge
    How To Download & Install Fabric Mods

Legends Core 1.7.10 Download Links:

For Minecraft 1.7.10

Download from Server 1Download from Server 2

Click to rate this post!
[Total: 32 Average: 3.4]

Share if you like